View Source

h1. Upgrade from 6.2

No changes in the engine.
No incompatible changes in the Workbench.
No incompatible changes in the Connectors.

h1. Upgrade from 6.1

h3. Repository upgrade

There are no changes in the repository format between 6.1 and 6.2, but it is highly recommended that the repository gets checked with the Storage tool.

# Stop GraphDB
# Use offline [Storage Tool|GraphDB-SE Storage Tool] to check repo integrity
## run *check* command that checks indexes consistence
### the check will report any problems into index consistence
### if no problem detected continue with *scan* command
### else use the [Storage Tool|GraphDB-SE Storage Tool] *rebuild* command to rebuild the broken index(exception _predLists_ rebuilds automatically on GraphDB start if you delete its files before that)
## run *scan* command that check the integrity of the data in statement indexes
### the scan will report any problem in statement indexes
### if no problem detected continue with upgrade
### else use the [Storage Tool|GraphDB-SE Storage Tool] *rebuild* command to rebuild the broken statement index from one of its siblings
# Start GraphDB

h3. Cluster upgrade


h3. Summary

The upgrade is simple as replacing the .WAR files, the only new step is the repo integrity check that can detect and fix problems related to older versions then 6.2

h1. Upgrade from 5.x