GraphDB-SE Installation

compared with
Version 9 by Reneta Popova
on Sep 18, 2014 17:28.

Key
This line was removed.
This word was removed. This word was added.
This line was added.

Changes (17)

View Page History
h1. Upgrading

In most cases, upgrading GraphDB-SE can be achieved simply by replacing the GraphDB and bundled 3rd party jar files. The required version of the Sesame framework for the recent GraphDB OWLIM versions is given in the following table:

|| GraphDB OWLIM version || Required Sesame version ||
| GraphDB-SE OWLIM-SE 5.4 | Sesame 2.7 |
| GraphDB-SE OWLIM-SE 5.3 | Sesame 2.6.7\+ |
| GraphDB-SE OWLIM-SE 5.2 | Sesame 2.6.7\+ |
| GraphDB-SE OWLIM-SE 5.1 | Sesame 2.6 |
| GraphDB-SE OWLIM-SE 5.0 | Sesame 2.6 |
| GraphDB-SE OWLIM-SE 4.3 | Sesame 2.6 |
| GraphDB-SE OWLIM-SE 4.2 | Sesame 2.5 |
| GraphDB-SE OWLIM-SE 4.1 | Sesame 2.4 |
| GraphDB-SE OWLIM-SE 4.0 | Sesame 2.4 |
| BigGraphDB BigOWLIM 3.5 | Sesame 2.3 |
| BigGraphDB BigOWLIM 3.4 | Sesame 2.3 |
| BigGraphDB BigOWLIM 3.3 | Sesame 2.3 |
| BigGraphDB BigOWLIM 3.2 | Sesame 2.3 |
| BigGraphDB BigOWLIM 3.1 | Sesame 2.2 |

Typically, the binary format of the storage files for different versions of BigGraphDB/GraphDB-SE BigOWLIM/GraphDB-SE are not compatible. However, storage files created with version 3.1 and upwards will be automatically upgraded when using a later version of GraphDB. However, this is a one-way process and no downgrade facility is provided.

{warning}