GraphDB-SE Installation

compared with
Current by Dimitar Manov
on Sep 18, 2014 19:02.

Key
This line was removed.
This word was removed. This word was added.
This line was added.

Changes (6)

View Page History
In most cases, upgrading GraphDB-SE can be achieved simply by replacing the GraphDB and bundled 3rd party jar files. The required version of the Sesame framework for the recent OWLIM versions is given in the following table:

|| OWLIM/GraphDB version || Required Sesame version ||
| GraphDB-SE 6.0 | Sesame 2.7.8 + new index format (autoupgraded) - the same for Owlim 5.5|
| OWLIM-SE 5.5 | Sesame 2.7.8 + new index format (autoupgraded)|
| OWLIM-SE 5.4 | Sesame 2.7.8 |
| OWLIM-SE 5.3 | Sesame 2.6.7\+ |
| OWLIM-SE 5.2 | Sesame 2.6.7\+ |
| BigOWLIM 3.1 | Sesame 2.2 |

Typically, Sometimes, the binary format of the storage files for different versions of BigOWLIM/OWLIM-SE/GraphDB-SE are not compatible. However, storage files created with version 3.1 and upwards will be automatically upgraded when using a later version of Owlim/GraphDB. However, this is a one-way process and no downgrade facility is provided.

{warning}
When upgrading to a later version of Owlim/GraphDB it is vitally important to make a back-up of your storage files before running the new software, because, otherwise, it will be impossible to revert to a previous version of GraphDB.
{warning}

h1. Easy install

GraphDB is normally built against the latest stable version of the [Aduna OpenRDF Sesame framework|http://www.openrdf.org/]. If using GraphDB with this version then the easiest way to deploy a GraphDB server instance is to copy the re-packaged Sesame Web applications (.war files) in to the Tomcat {{webapps}} directory. These can be found in the {{sesame_owlim}} directory in the GraphDB distribution ZIP file. These Web applications have been modified as follows:

* *openrdf-sesame.war:* The Sesame server application. All GraphDB-SE and 3{^}rd^ party jar files have been added to this package, so that it can be used immediately after deployment.