Version 5 by Stefan Enev
on Oct 26, 2012 15:56.

compared with
Version 6 by Stefan Enev
on Oct 26, 2012 16:04.

Key
This line was removed.
This word was removed. This word was added.
This line was added.

Changes (5)

View Page History
Ontotext are pleased to announce the release of KIM 3.6 which brings significant performance and stability improvements. This release has been coordinated with the latest release of the [OWLIM family|http://www.ontotext.com/owlim] and most notably allows smooth integration with [OWLIM|http://www.ontotext.com/owlim]'s replication cluster. The combination achieves resilience and linearly scalable parallel query performance and also makes KIM easily deployable in industrial environments such as [The National Archives|http://www.nationalarchives.gov.uk/].

The most important changes and improvements cover the following areas:
* Indexing and search
** Fully compliant [SPARQL 1.1|http://www.w3.org/TR/sparql11-query/] support and full-text RDF indexing through the updated [OWLIM 5.2|http://www.ontotext.com/owlim/change_log.html].
** Support for the [N-Quads RDF format|http://sw.deri.org/2008/07/n-quads/]
** Handles millions of documents and hundreds of millions of annotations
** Custom KIM Extensions - write your own extensions for KIM(in Java), which will run in the same virtual machine as the server, for the sake of lowest communication overhead.
* Text analysis
** Improved text analysis capabilities based on [GATE|http://gate.ac.uk/] 7.0.
** Refined default "World Knowledge Base".
* User interface (UI)
* Notes on upgrading
** Although the Java API of the KIM Server has been altered significantly, the overall structure remains the same. If your client software uses a removed method for some interface, please consult the interface Javadocs to find a replacement method.
** Upgrading from an existing KIM 3.0 installation is possible, but complicated. Upgrading the [OWLIM|http://www.ontotext.com/owlim] image from 3.x to 5.x is not straightforward, as migration tools exist only for the purpose of upgrading from [OWLIM|http://www.ontotext.com/owlim] 4.x to 5.x. We will post instructions as soon as the [OWLIM|http://www.ontotext.com/owlim] team posts instructions for upgrading from 3.x to 5.x. Re-populating your data is always an option, though not very efficient for large amounts of data.
** KIM 3.6 requires Java 6 [Java Development Kit 6|http://www.oracle.com/technetwork/java/javase/readme-142177.html] and is not compatible with Java 7. Although we are keen to provide Java 7 support, there are no such plans yet.

This is not the complete changelog as the full list of improvements is too long. Please contact us if you are interested in any more details.